Consultas, desarrollo de programas y petición de presupuestos:

jueves, 8 de enero de 2015

Resolver: ERROR: #2: Cannot load class 'XXX': Bytecode too recent.Please upgrade Gambas


Resolver: ERROR: #2:
Cannot load class 'XXX':
Bytecode too recent.

Please upgrade Gambas



Este error se produce cuando intentamos ejecutar un programa hecho en gambas3 cuando la versión del gambas instalado en nuestro ordenador es inferior a la que necesita el programa. Hacer notar que este mensaje solo se muestra en consola, si lo intentamos ejecutar desde menu o desde algún lanzador no muestra ningún mensaje.

En la mayoria de las distribuciones, te puedes instalar gambas3 en la version 3.1.1
Pero esta versión ya es bastante antigua y se han corregido muchos errores, en las versiones siguientes.

Para actualizar la versión de gambas, depende un poco de la distribución que tengas:

Por ejemplo:

Para Debian, tienes que usar el repositorio SID (lo explique en esta entrada http://jsbsan.blogspot.com.es/2014/07/actualizacion-gambas-354-en-el.html)

Para Ubuntu y Derivadas:
Los paquetes binarios de Gambas3 más recientes se pueden encontrar en un PPA creado y mantenido por el 'Gambas Team'.
Ello te permite instalar la versión estable más reciente de Gambas3 sin la necesidad de compilar.
Primeramente añade la PPA a tu fichero sources.list. Abre un terminal y escribe:
$ sudo add-apt-repository ppa:gambas-team/gambas3

Luego actualiza las fuentes e instala Gambas3:
$ sudo apt-get update $ sudo apt-get install gambas3

Tras la instalación, encontrarás Gambas3 en el menú 'Desarrollo' o 'Programación'.
Ver tambien enlace:

Saludos

No hay comentarios:

Publicar un comentario